Start a conversation

Can I get older installers that work on OS X 10.9 - 10.12?

Products up to Elka-X have installers that will allow you to install on legacy Mac systems from OS X 10.9 - to 10.12. However, products released after Elka-X, as well as all newly updated installers, require macOS 10.13 and higher.

Below is a list of links to the last compatible installers for OS X 10 - 10.12

Voltage Modular 2.5.5

DCO-106 v1.2.0

CA2600 v1.2.0

Surrealistic MG-1 Plus v1.2.0

Polymode v1.2.0

Eight Voice v1.2.0

PS-20 v1.2.0

Memorymode v1.2.0

Mercury-4 v1.5.1

Stardust 201 Tape Echo v1.0.11

Quadra v1.0.4

Rackmode Processors v1.0.6

Dreamsynth v1.0.8

Miniverse v1.0.13

Lowdown v1.0.4

Galactic v1.0.4

Elka-X v1.0.5

Choose files or drag and drop files
Was this article helpful?
  1. Danny L

  2. Posted
  3. Updated